Verification is currently underway for the maintenance items.
Posted May 01, 2025 - 21:33 UTC
Update
We have extended the maintenance window by 1 hour.
Posted May 01, 2025 - 20:58 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 01, 2025 - 13:00 UTC
Update
This infrastructure maintenance has been postponed to Thursday May 1.
Posted Apr 29, 2025 - 03:09 UTC
Scheduled
We will be performing scheduled system maintenance and upgrades to improve our infrastructure and enhance overall service performance.
During the maintenance window: - The Silicon Valley region will be unavailable - Services in the Silicon Valley region will experience downtime - Traffic will be rerouted from Silicon Valley to other regions, potentially causing increased latency
Note: While we've allocated a 7-hour maintenance window for thorough completion, we anticipate finishing sooner.
We'll provide ongoing status updates.
Posted Apr 25, 2025 - 16:56 UTC
This scheduled maintenance affected: CDN (Silicon Valley) and Cloud Network (Silicon Valley).