Nirvana Labs

Report a problemSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Network Instability in Seattle
Resolved

We have isolated the faulty hardware and are currently working to restore full capacity in the Seattle region.

Tue, Apr 29, 2025, 03:11 AM
(11 months ago)
·
Affected components

No components marked as affected

Updates

Identified

We have isolated the faulty hardware and are currently working to restore full capacity in the Seattle region.

Tue, Apr 29, 2025, 03:11 AM

Investigating

We are seeing network instability in our Seattle region.

Mon, Apr 28, 2025, 07:48 PM(7 hours earlier)